Cool FormKit Lite – Advanced Form Builder for Elementor <= 2.7.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Form Field Custom ID
- ID
- WPSEC-2026-2061
- Plugin
- Cool FormKit Lite – Advanced Form Builder for Elementor (extensions-for-elementor-form)
- Affected
- all versions before 2.7.10
- Remediation
- Update to 2.7.10 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- Cool FormKit Lite – Advanced Form Builder for Elementor on WPSec AttackSurface
- Fix released
- Published
Also published later by Wordfence as CVE-2026-118500, on 2026-10-29.
Description
The Cool FormKit Lite – Advanced Form Builder for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the form field Custom ID used by conditional logic in all versions up to, and including, 2.7.9. This is due to insufficient input sanitization and output escaping. The Custom ID is only restricted in the Elementor editor's client-side script and is not sanitized on the server. It is used as a key in the conditional-logic data, and the front-end script places that key into HTML strings that jQuery parses. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2061/
- https://plugins.svn.wordpress.org/extensions-for-elementor-form/tags/2.7.10/
- https://wordpress.org/plugins/extensions-for-elementor-form/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS