PPWP – Password Protect Pages <= 1.9.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'ppwp' Shortcode
- ID
- WPSEC-2026-2062
- Plugin
- PPWP – Password Protect Pages (password-protect-page)
- Affected
- all versions before 1.9.27
- Remediation
- Update to 1.9.27 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- PPWP – Password Protect Pages on WPSec AttackSurface
- Fix released
- Published
Description
The Password Protect Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's [ppwp] shortcode in all versions up to, and including, 1.9.26 due to insufficient input sanitization and output escaping when building the password form template, where user-supplied shortcode attribute values could contain placeholder tokens that were later expanded in an already-escaped context. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2062/
- https://plugins.svn.wordpress.org/password-protect-page/tags/1.9.27/
- https://wordpress.org/plugins/password-protect-page/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS