Vulnerabilities / Post Duplicator / WPSEC-2026-2066

Post Duplicator <= 3.0.16 - Authenticated (Contributor+) Sensitive Information Exposure via Parent Posts REST Route

Medium 4.3 CWE-200Fixed in 3.0.17
ID
WPSEC-2026-2066
Plugin
Post Duplicator (post-duplicator)
Affected
from 3.0.0 before 3.0.17
Remediation
Update to 3.0.17 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
Attack surface
Post Duplicator on WPSec AttackSurface
Fix released
Published

Description

The Post Duplicator plugin for WordPress is vulnerable to Sensitive Information Exposure via the parent-posts REST route in all versions from 3.0.0 up to, and including, 3.0.16, due to the route checking only the generic edit_posts capability and returning every published, draft and private post of the requested post type without checking whether the current user may read each post. This makes it possible for authenticated attackers, with Contributor-level access and above, to list the IDs and titles of other users' draft and private posts of any post type.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0