Vulnerabilities / Booking System / WPSEC-2026-2069
Booking System <= 2.1.0.6 - Reflected Cross-Site Scripting via 'tab' Parameter
Medium 6.1
CWE-79Fixed in 2.1.0.7
- ID
- WPSEC-2026-2069
- Plugin
- WP Booking System – Booking Calendar (wp-booking-system)
- Affected
- all versions before 2.1.0.7
- Remediation
- Update to 2.1.0.7 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- Booking System on WPSec AttackSurface
- Fix released
- Published
Description
The WP Booking System plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab' parameter on the form edit admin page in all versions up to, and including, 2.1.0.6. This is due to insufficient escaping, as the value is only passed through sanitize_text_field, which does not encode quotes for an attribute context. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in an administrator's browser if they can trick the administrator into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2069/
- https://plugins.svn.wordpress.org/wp-booking-system/tags/2.1.0.7/
- https://wordpress.org/plugins/wp-booking-system/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS