Vulnerabilities / FluentCRM – Email Newsletter, Automation, Email Marketing, Email Campaigns, Optins, Leads, and CRM Solution / WPSEC-2026-2099
FluentCRM – Email Newsletter, Automation, Email Marketing, Email Campaigns, Optins, Leads, and CRM Solution <= 3.2.6 - Authenticated (Subscriber+) Authentication Bypass to Contact Takeover via Unverified Email Change
Medium 5.4
CWE-287Fixed in 3.3.0
- ID
- WPSEC-2026-2099
- Plugin
- FluentCRM – Email Newsletter, Automation, Email Marketing, Email Campaigns, Optins, Leads, and CRM Solution (fluent-crm)
- Affected
- all versions before 3.3.0
- Remediation
- Update to 3.3.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-287
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-30
- Attack surface
- FluentCRM – Email Newsletter, Automation, Email Marketing, Email Campaigns, Optins, Leads, and CRM Solution on WPSec AttackSurface
- Fix released
- Published
Description
The FluentCRM plugin for WordPress is vulnerable to an authentication bypass in all versions up to, and including, 3.2.6 due to the current contact being matched to the logged-in user by email address without requiring that email to be verified. Because WordPress users can change their own account email without confirmation, this makes it possible for authenticated attackers with subscriber-level access and above to set their email to a victim's address and take over that victim's CRM contact, including viewing and modifying its profile, preferences and personalized data.
References
- https://wpsec.com/vuln/WPSEC-2026-2099/
- https://plugins.svn.wordpress.org/fluent-crm/tags/3.3.0/
- https://wordpress.org/plugins/fluent-crm/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS