Vulnerabilities / Pie Register / WPSEC-2026-2124
Pie Register <= 3.8.4.15 - Cross-Site Request Forgery to Registration Form Deletion
Medium 4.3
CWE-352Fixed in 3.8.4.16
- ID
- WPSEC-2026-2124
- Plugin
- Pie Register – User Registration, Profiles & Content Restriction (pie-register)
- Affected
- all versions before 3.8.4.16
- Remediation
- Update to 3.8.4.16 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- Pie Register on WPSec AttackSurface
- Fix released
- Published
Description
The pie-register plugin for WordPress is vulnerable to Cross-Site Request Forgery via the registration form delete action in all versions up to, and including, 3.8.4.15. This is due to missing nonce validation in the pie_main() function, which runs on 'init' and deletes or disables a registration form whenever the 'prfrmid' and 'action=delete' GET parameters are present and the current user is an administrator. This makes it possible for unauthenticated attackers to delete or disable registration forms by tricking a site administrator into clicking a link or loading a page.
References
- https://wpsec.com/vuln/WPSEC-2026-2124/
- https://plugins.svn.wordpress.org/pie-register/tags/3.8.4.16/
- https://wordpress.org/plugins/pie-register/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS