GeoDirectory – WP Business Directory Plugin and Classified Listings Directory <= 2.8.199 - Authenticated (Subscriber+) Stored Cross-Site Scripting via AyeCode UI Popover Attributes in Listing Content
- ID
- WPSEC-2026-2128
- Plugin
- GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (geodirectory)
- Affected
- all versions before 2.8.200
- Remediation
- Update to 2.8.200 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
- Attack surface
- GeoDirectory – WP Business Directory Plugin and Classified Listings Directory on WPSec AttackSurface
- Fix released
- Published
Description
The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'data-toggle' and 'data-bs-toggle' attributes set to 'popover-html' in listing content and HTML/textarea custom fields in all versions up to, and including, 2.8.199, due to insufficient input sanitization and output escaping. The plugin's kses filtering keeps data-* attributes, and the bundled AyeCode UI script turns every element with a 'popover-html' toggle into a popover with HTML enabled and sanitization turned off, so the element's popover content is inserted into the page as raw HTML. This makes it possible for authenticated attackers with subscriber-level access and above, where front-end listing submission is enabled, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page and opens the popover.
References
- https://wpsec.com/vuln/WPSEC-2026-2128/
- https://plugins.svn.wordpress.org/geodirectory/tags/2.8.200/
- https://wordpress.org/plugins/geodirectory/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS