Vulnerabilities / Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery / WPSEC-2026-2134
Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 4.5.4 - Authenticated (Author+) Missing Authorization to Gallery Image Metadata Modification
Medium 4.3
CWE-862Fixed in 4.5.5
- ID
- WPSEC-2026-2134
- Plugin
- Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery (nextgen-gallery)
- Affected
- all versions before 4.5.5
- Remediation
- Update to 4.5.5 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
- Attack surface
- Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery on WPSec AttackSurface
- Fix released
- Published
Description
The NextGEN Gallery plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 4.5.4. This is due to a missing capability and ownership check in the NextGEN media upload tab's save handler, which only verified a nonce printed for any user with the upload_files capability. This makes it possible for authenticated attackers, with Author-level access and above, to overwrite the slug, alt text and description of any NextGEN Gallery image on the site, including images in other users' galleries.
References
- https://wpsec.com/vuln/WPSEC-2026-2134/
- https://plugins.svn.wordpress.org/nextgen-gallery/tags/4.5.5/
- https://wordpress.org/plugins/nextgen-gallery/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS