Blocksy Companion <= 2.1.60 - Authenticated (Contributor+) Sensitive Information Exposure via About Me Block

Medium 4.3 CWE-200Fixed in 2.1.61
ID
WPSEC-2026-2136
Plugin
Blocksy Companion (blocksy-companion)
Affected
all versions before 2.1.61
Remediation
Update to 2.1.61 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
Attack surface
Blocksy Companion on WPSec AttackSurface
Fix released
Published

Description

The Blocksy Companion plugin for WordPress is vulnerable to Sensitive Information Exposure via the About Me block in all versions up to, and including, 2.1.60, due to the block's 'wp_user' attribute accepting any user ID without checking that the user has published content. The block can be rendered in a post or through the blocksy_get_dynamic_block_view AJAX action. This makes it possible for authenticated attackers, with contributor-level access and above, to expose the display name, biography, avatar and author archive slug of any user, including subscribers and customers who are not public authors.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0