Vulnerabilities / Event Tickets and Registration / WPSEC-2026-2143
Event Tickets and Registration <= 5.30.2 - Cross-Site Request Forgery to Attendee Information Update via My Tickets Page
Medium 4.3
CWE-352Fixed in 5.30.3
- ID
- WPSEC-2026-2143
- Plugin
- Event Tickets and Registration (event-tickets)
- Affected
- all versions before 5.30.3
- Remediation
- Update to 5.30.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
- Attack surface
- Event Tickets and Registration on WPSec AttackSurface
- Fix released
- Published
Description
The Event Tickets and Registration plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.30.2. This is due to missing nonce validation in the update_tickets() function, which handles attendee updates submitted from the My Tickets page. This makes it possible for unauthenticated attackers to change the name, email address, opt-out setting and RSVP status of a logged-in user's attendee records via a forged request, if they can trick the user into performing an action such as clicking a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2143/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3/
- https://wordpress.org/plugins/event-tickets/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS