The Events Calendar <= 6.18.2 - Unauthenticated Sensitive Information Exposure via Password-Protected Linked Organizers and Venues in REST API
- ID
- WPSEC-2026-2146
- Plugin
- The Events Calendar (the-events-calendar)
- Affected
- from 6.15.0 before 6.18.3
- Remediation
- Update to 6.18.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin High · Affected versions High among sites WPSec scans, 2026-10-30
- Attack surface
- The Events Calendar on WPSec AttackSurface
- Fix released
- Published
Description
The The Events Calendar plugin for WordPress is vulnerable to Sensitive Information Exposure via the TEC REST API single-entity read endpoint in all versions from 6.15.0 up to, and including, 6.18.2, due to the endpoint turning off the password check for the whole request (a global '__return_false' filter on 'post_password_required') once the password for the requested entity is supplied. Linked Organizers and Venues serialized in the same response therefore skip their own password check, even when they are protected by different passwords. This makes it possible for unauthenticated attackers who know the password of one event to read the protected details of linked organizers and venues whose passwords they do not know.
References
- https://wpsec.com/vuln/WPSEC-2026-2146/
- https://plugins.svn.wordpress.org/the-events-calendar/tags/6.18.3/
- https://wordpress.org/plugins/the-events-calendar/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS