Uncanny Toolkit for LearnDash <= 3.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via uo_login Shortcode Label Attributes

Medium 6.4 CWE-79Fixed in 3.8.3
ID
WPSEC-2026-2151
Plugin
Uncanny Toolkit for LearnDash (uncanny-learndash-toolkit)
Affected
all versions before 3.8.3
Remediation
Update to 3.8.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-30
Attack surface
Uncanny Toolkit for LearnDash on WPSec AttackSurface
Fix released
Published

Description

The Uncanny Toolkit for LearnDash plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'username-label' and 'password-label' attributes of the [uo_login] shortcode in all versions up to, and including, 3.8.2. This is due to the plugin echoing these values without escaping inside a single-quoted JavaScript string in an inline script. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages. The scripts run whenever a logged-out visitor opens an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0