Vulnerabilities / Forminator Forms / WPSEC-2026-2181

Forminator Forms <= 1.58.3 - Unauthenticated Arbitrary Shortcode Execution via Post Data Field

High 7.3 CWE-94Fixed in 1.58.4
ID
WPSEC-2026-2181
Plugin
Forminator Forms – Contact Form, Payment Form & Custom Form Builder (forminator)
Affected
all versions before 1.58.4
Remediation
Update to 1.58.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-94
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Forminator Forms on WPSec AttackSurface
Fix released
Published

Description

The Forminator Forms plugin for WordPress is vulnerable to Arbitrary Shortcode Execution via the Post Data field in all versions up to, and including, 1.58.3. This is due to the plugin saving submitted post content, titles and excerpts into the created post without neutralizing shortcode brackets, regardless of whether the submitter is allowed to edit posts. This makes it possible for unauthenticated attackers to plant arbitrary shortcodes in the created post, which execute when the post is rendered, for example when the form publishes submitted posts or when a site user previews the submitted draft. Exploitation requires a public form with a Post Data field.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0