Vulnerabilities / Smart Post / WPSEC-2026-2189
Smart Post <= 4.0.9 - Cross-Site Request Forgery to Shortcode Import
Medium 4.3
CWE-352Fixed in 4.0.10
- ID
- WPSEC-2026-2189
- Plugin
- Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News (post-carousel)
- Affected
- all versions before 4.0.10
- Remediation
- Update to 4.0.10 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Smart Post on WPSec AttackSurface
- Fix released
- Published
Description
The Smart Post plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.9 due to the import and export AJAX handlers only verifying the nonce when one was supplied. This makes it possible for unauthenticated attackers to import arbitrary shortcode configurations via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2189/
- https://plugins.svn.wordpress.org/post-carousel/tags/4.0.10/
- https://wordpress.org/plugins/post-carousel/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS