Vulnerabilities / Post Carousel / WPSEC-2026-2190

Post Carousel <= 4.0.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Attributes

Medium 6.4 CWE-79Fixed in 4.0.10
ID
WPSEC-2026-2190
Plugin
Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News (post-carousel)
Affected
from 4.0.0 before 4.0.10
Remediation
Update to 4.0.10 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Post Carousel on WPSec AttackSurface
Fix released
Published

Description

The Smart Post plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'titleHTMLTag' attribute of the post blocks and the 'collapsibleColor' attribute of the Table of Contents block in all versions from 4.0.0 up to, and including, 4.0.9, due to insufficient input sanitization and output escaping. The title tag value is only passed through esc_html() before being used as the element name, which leaves spaces and '=' in place, and the collapsible icon color is concatenated unescaped into SVG attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0