AnyWhere Elementor <= 1.3.0 - Authenticated (Subscriber+) SQL Injection via 'q' Parameter
- ID
- WPSEC-2026-2200
- Plugin
- Dynific Addons for Elementor (formerly Anywhere Elementor) (anywhere-elementor)
- Affected
- all versions before 1.3.1
- Remediation
- Update to 1.3.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weakness
- CWE-89
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- AnyWhere Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to SQL Injection via the 'q' parameter of the ae_prev_post AJAX action in all versions up to, and including, 1.3.0. This is due to the search term being concatenated into the posts_where clause after only esc_like(), which does not escape quotes, and to the handler checking only a nonce that is printed to every front-end visitor, with no capability check. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries to existing queries and extract sensitive information from the database.
References
- https://wpsec.com/vuln/WPSEC-2026-2200/
- https://plugins.svn.wordpress.org/anywhere-elementor/tags/1.3.1/
- https://wordpress.org/plugins/anywhere-elementor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS