Vulnerabilities / AnyWhere Elementor / WPSEC-2026-2201
AnyWhere Elementor <= 1.3.0 - Authenticated (Contributor+) Information Exposure via dynific_template Shortcode
Medium 4.3
CWE-200Fixed in 1.3.1
- ID
- WPSEC-2026-2201
- Plugin
- Dynific Addons for Elementor (formerly Anywhere Elementor) (anywhere-elementor)
- Affected
- from 1.3 before 1.3.1
- Remediation
- Update to 1.3.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- AnyWhere Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to Information Exposure via the 'post_id' attribute of the dynific_template and INSERT_ELEMENTOR shortcodes in all versions up to, and including, 1.3.0. This is due to the shortcode rendering the template in the context of any supplied post ID without checking the post's status or the viewer's permissions. This makes it possible for authenticated attackers, with Contributor-level access and above, to display the content of private, draft and password-protected posts.
References
- https://wpsec.com/vuln/WPSEC-2026-2201/
- https://plugins.svn.wordpress.org/anywhere-elementor/tags/1.3.1/
- https://wordpress.org/plugins/anywhere-elementor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS