Vulnerabilities / Directorist: AI-Powered Business Directory, Listings & Classified Ads / WPSEC-2026-2227
Directorist: AI-Powered Business Directory, Listings & Classified Ads <= 8.10.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Single Listing Shortcode Placeholder
Medium 6.4
CWE-79Fixed in 8.10.7
- ID
- WPSEC-2026-2227
- Plugin
- Directorist: AI-Powered Business Directory, Listings & Classified Ads (directorist)
- Affected
- all versions before 8.10.7
- Remediation
- Update to 8.10.7 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Directorist: AI-Powered Business Directory, Listings & Classified Ads on WPSec AttackSurface
- Fix released
- Published
Description
The Directorist plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the single listing dummy shortcode placeholder in all versions up to, and including, 8.10.6 due to insufficient output escaping of the shortcode name and its attributes when the placeholder is rendered. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the injected placeholder.
References
- https://wpsec.com/vuln/WPSEC-2026-2227/
- https://plugins.svn.wordpress.org/directorist/tags/8.10.7/
- https://wordpress.org/plugins/directorist/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS