WP Photo Album Plus <= 9.3.05.003 - Unauthenticated Stored Cross-Site Scripting via User-Agent Header

High 7.2 CWE-79Fixed in 9.3.06.001
ID
WPSEC-2026-2250
Plugin
WP Photo Album Plus (wp-photo-album-plus)
Affected
all versions before 9.3.06.001
Remediation
Update to 9.3.06.001 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WP Photo Album Plus on WPSec AttackSurface
Fix released
Published

Description

The WP Photo Album Plus plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the User-Agent header in all versions up to, and including, 9.3.05.003 due to insufficient input sanitization when session data is stored and insufficient output escaping when the session list is displayed in the admin maintenance popup. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that will execute whenever an administrator views the session list on the maintenance page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0