Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare <= 2.4.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'font_link' Parameter
- ID
- WPSEC-2026-2259
- Plugin
- ShopEngine Gutenberg WooCommerce Builder Blocks Addon – All in One WooCommerce Solution (blocks-for-shopengine)
- Affected
- all versions before 2.4.4
- Remediation
- Update to 2.4.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Gutenberg WooCommerce Builder Blocks for ShopEngine, Variation Swatches, Wishlist, Products Compare on WPSec AttackSurface
- Fix released
- Published
Description
The ShopEngine Gutenberg WooCommerce Builder Blocks Addon plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'font_link' parameter of the gutenova_store_css AJAX action in all versions up to, and including, 2.4.3 due to insufficient output escaping when the stored gutenova_font_link post meta is placed inside a double-quoted JavaScript string in the block editor's inline script. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts that execute whenever a user, such as an administrator, opens the affected post in the block editor.
References
- https://wpsec.com/vuln/WPSEC-2026-2259/
- https://plugins.svn.wordpress.org/blocks-for-shopengine/tags/2.4.4/
- https://wordpress.org/plugins/blocks-for-shopengine/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS