Vulnerabilities / Events Made Easy / WPSEC-2026-2263

Events Made Easy <= 3.3.2 - Unauthenticated Reflected Cross-Site Scripting via Event List Filter Parameters

Medium 6.1 CWE-79Fixed in 3.3.3
ID
WPSEC-2026-2263
Plugin
Events Made Easy (events-made-easy)
Affected
all versions before 3.3.3
Remediation
Update to 3.3.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Events Made Easy on WPSec AttackSurface
Fix released
Published

Description

The Events Made Easy plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the event list filter parameters (such as 'eme_city_filter', 'eme_cat_filter' or 'eme_scope_filter') in all versions up to, and including, 3.3.2, due to insufficient output escaping. On paged event lists the filter values are only passed through sanitize_text_field, which keeps quotes, then added to the previous and next page links with add_query_arg, which does not encode them, and printed into single-quoted href attributes without esc_url(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0