WCFM Membership – WooCommerce Memberships for Multivendor Marketplace <= 2.12.0 - Authenticated (Vendor+) Missing Authorization to Membership Plan Change
- ID
- WPSEC-2026-2276
- Plugin
- WCFM Membership – WooCommerce Memberships for Multivendor Marketplace (wc-multivendor-membership)
- Affected
- all versions before 2.12.1
- Remediation
- Update to 2.12.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
- Attack surface
- WCFM Membership – WooCommerce Memberships for Multivendor Marketplace on WPSec AttackSurface
- Fix released
- Published
Description
The WCFM Membership – WooCommerce Memberships for Multivendor Marketplace plugin for WordPress is vulnerable to unauthorized modification of data via the wcfmvm_membership_change AJAX action in all versions up to, and including, 2.12.0, due to a capability check that accepts marketplace vendor roles for this administrator-only "Change or Upgrade" action and missing validation that the target plan is a published membership. This makes it possible for authenticated attackers with vendor-level access to move their own account onto any membership plan, including paid, disabled or unpublished plans, without paying for it.
References
- https://wpsec.com/vuln/WPSEC-2026-2276/
- https://plugins.svn.wordpress.org/wc-multivendor-membership/tags/2.12.1/
- https://wordpress.org/plugins/wc-multivendor-membership/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS