Product Slider for WooCommerce <= 2.9.0 - Authenticated (Administrator+) Stored Cross-Site Scripting via Custom JS Setting
- ID
- WPSEC-2026-2290
- Plugin
- Product Slider, Product Carousel and Product Grid Gallery for WooCommerce – Reno Product Slider (formerly Product Slider for WooCommerce) (woo-product-slider)
- Affected
- from 2.8.7 before 2.9.1
- Remediation
- Update to 2.9.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Product Slider for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Reno Product Slider (formerly Product Slider for WooCommerce) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS setting in versions 2.8.7 up to, and including, 2.9.0. This is due to the plugin letting any user who can save its settings store the Custom JS option, which is only stripped of HTML tags and is then printed as an inline script on the front end, without checking for the unfiltered_html capability. This makes it possible for authenticated attackers with administrator-level access to inject arbitrary web scripts in pages that execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2290/
- https://plugins.svn.wordpress.org/woo-product-slider/tags/2.9.1/
- https://wordpress.org/plugins/woo-product-slider/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS