Vulnerabilities / Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder / WPSEC-2026-2295
Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder <= 6.2.16 - Authenticated (Fluent Forms Manager+) Server-Side Request Forgery via Mailchimp API Key
Medium 5.5
CWE-918Fixed in 6.2.17
- ID
- WPSEC-2026-2295
- Plugin
- Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder (fluentform)
- Affected
- all versions before 6.2.17
- Remediation
- Update to 6.2.17 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-918
- Usage
- Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
- Attack surface
- Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder on WPSec AttackSurface
- Fix released
- Published
Description
The Fluent Forms plugin for WordPress is vulnerable to Server-Side Request Forgery via the Mailchimp API key in the global settings in all versions up to, and including, 6.2.16, due to the data-center part of the API key being placed into the API request host without validation. This makes it possible for authenticated attackers who are Fluent Forms managers with settings-manager permission to make HTTPS GET requests to arbitrary hosts from the web application, which can be used to reach internal services.
References
- https://wpsec.com/vuln/WPSEC-2026-2295/
- https://plugins.svn.wordpress.org/fluentform/tags/6.2.17/
- https://wordpress.org/plugins/fluentform/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS