Easy Social Icons <= 4.0.2 - Authenticated (Administrator+) Stored Cross-Site Scripting via Icon Colour Settings and Icon Titles
- ID
- WPSEC-2026-2327
- Plugin
- Easy Social Icons (easy-social-icons)
- Affected
- all versions before 4.0.3
- Remediation
- Update to 4.0.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Easy Social Icons on WPSec AttackSurface
- Fix released
- Published
Description
The Easy Social Icons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the icon colour settings and the icon title in all versions up to, and including, 4.0.2, due to insufficient input sanitization and output escaping. The colour settings were registered without sanitization and printed unescaped into an inline stylesheet on every front-end page, and icon titles were printed unescaped into HTML attributes of the front-end icon markup. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2327/
- https://plugins.svn.wordpress.org/easy-social-icons/tags/4.0.3/
- https://wordpress.org/plugins/easy-social-icons/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS