Vulnerabilities / Co-Authors Plus / WPSEC-2026-2329

Co-Authors Plus <= 4.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Byline Template Tags

Medium 6.4 CWE-79Fixed in 4.2.0
ID
WPSEC-2026-2329
Plugin
Co-Authors Plus (co-authors-plus)
Affected
all versions before 4.2.0
Remediation
Update to 4.2.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
Co-Authors Plus on WPSec AttackSurface
Fix released
Published

Description

The Co-Authors Plus plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plain byline template tags (such as coauthors()) in all versions up to, and including, 4.1.3 due to insufficient output escaping of co-author field values, tag values and the user_login fallback in coauthors__echo(). This makes it possible for authenticated attackers, with contributor-level access and above, who can write raw guest author profile meta such as the display name, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the byline.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0