Vulnerabilities / Co-Authors Plus / WPSEC-2026-2330
Co-Authors Plus <= 4.1.3 - Unauthenticated Sensitive Information Exposure via '/wp/v2/coauthors' REST Route
Medium 5.3
CWE-200Fixed in 4.2.0
- ID
- WPSEC-2026-2330
- Plugin
- Co-Authors Plus (co-authors-plus)
- Affected
- from 3.5 before 4.2.0
- Remediation
- Update to 4.2.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Co-Authors Plus on WPSec AttackSurface
- Fix released
- Published
Description
The Co-Authors Plus plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.1.3 via the '/wp/v2/coauthors' REST route. The author taxonomy was exposed through the default core terms controller without any permission check, and author term names are user logins. This makes it possible for unauthenticated attackers to enumerate the login names of users on the site, which WordPress core otherwise keeps out of anonymous REST responses.
References
- https://wpsec.com/vuln/WPSEC-2026-2330/
- https://plugins.svn.wordpress.org/co-authors-plus/tags/4.2.0/
- https://wordpress.org/plugins/co-authors-plus/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS