Vulnerabilities / LatePoint / WPSEC-2026-2338

LatePoint <= 5.7.6 - Authenticated (Agent+) Account Takeover of Subscriber-Level Users via 'wordpress_user_id' Parameter

Medium 4.2 CWE-269Fixed in 5.7.7
ID
WPSEC-2026-2338
Plugin
Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress (latepoint)
Affected
all versions before 5.7.7
Remediation
Update to 5.7.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-269
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
Attack surface
LatePoint on WPSec AttackSurface
Fix released
Published

Description

The LatePoint plugin for WordPress is vulnerable to Privilege Escalation via Account Takeover in all versions up to, and including, 5.7.6, due to the customer create and update handlers and the order editor accepting the 'wordpress_user_id' and 'password' fields from any LatePoint backend user. This makes it possible for authenticated attackers, with LatePoint Agent-level access and above, to link a customer record they control to an existing subscriber- or customer-level WordPress account and set that account's password through the customer password reset, on sites with the 'Use WordPress users as customers' option enabled.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0