Vulnerabilities / WP Sort Order / WPSEC-2026-2343

WP Sort Order <= 1.3.6 - Authenticated (Administrator+) Stored Cross-Site Scripting via Extras Order Setting

Medium 4.4 CWE-79Fixed in 1.3.7
ID
WPSEC-2026-2343
Plugin
WP Sort Order (wp-sort-order)
Affected
all versions before 1.3.7
Remediation
Update to 1.3.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WP Sort Order on WPSec AttackSurface
Fix released
Published

Description

The WP Sort Order plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the wpso_extras_order option in all versions up to, and including, 1.3.6 due to insufficient input sanitization and output escaping, as the stored values are echoed unescaped into inline JavaScript in the admin footer. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in admin pages that will execute whenever a user accesses an affected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0