Photo Gallery – Responsive Image Galleries by Supsystic <= 1.21.6 - Authenticated (Administrator+) Stored Cross-Site Scripting via Social Sharing HTML Gallery Setting
- ID
- WPSEC-2026-2344
- Plugin
- Photo Gallery by Supsystic – Image Gallery, Masonry, Albums & Lightbox (gallery-by-supsystic)
- Affected
- all versions before 1.21.7
- Remediation
- Update to 1.21.7 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Photo Gallery – Responsive Image Galleries by Supsystic on WPSec AttackSurface
- Fix released
- Published
Description
The Photo Gallery by Supsystic plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the socialSharing.html gallery setting in all versions up to, and including, 1.21.6 due to insufficient input sanitization on save and missing output escaping in the gallery shortcode template. This makes it possible for authenticated attackers with administrator-level permissions and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a page containing the gallery. This only affects multi-site installations and installations where unfiltered_html has been disabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2344/
- https://plugins.svn.wordpress.org/gallery-by-supsystic/tags/1.21.7/
- https://wordpress.org/plugins/gallery-by-supsystic/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS