Vulnerabilities / WCFM – Frontend Manager for WooCommerce / WPSEC-2026-2347
WCFM – Frontend Manager for WooCommerce <= 6.8.1 - Authenticated (Vendor+) Missing Authorization to Site-Wide Capability Settings Modification
Medium 6.5
CWE-862Fixed in 6.8.2
- ID
- WPSEC-2026-2347
- Plugin
- WCFM – Frontend Manager for WooCommerce (wc-frontend-manager)
- Affected
- all versions before 6.8.2
- Remediation
- Update to 6.8.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- WCFM – Frontend Manager for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The WCFM – Frontend Manager for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data via the 'wcfm-capability' AJAX controller in all versions up to, and including, 6.8.1, due to a missing capability check: the handler only requires 'manage_woocommerce' or 'shop_staff', and the plugin itself gives the vendor role 'manage_woocommerce'. This makes it possible for authenticated attackers with vendor-level access and above to overwrite the site-wide capability settings that restrict all vendors, shop managers and shop staff.
References
- https://wpsec.com/vuln/WPSEC-2026-2347/
- https://plugins.svn.wordpress.org/wc-frontend-manager/tags/6.8.2/
- https://wordpress.org/plugins/wc-frontend-manager/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS