Vulnerabilities / Welcart e-Commerce / WPSEC-2026-2354
Welcart e-Commerce <= 2.12.6 - Unauthenticated Reflected Cross-Site Scripting via Payment Error Page Parameters
Medium 6.1
CWE-79Fixed in 2.12.7
- ID
- WPSEC-2026-2354
- Plugin
- Welcart e-Commerce (usc-e-shop)
- Affected
- all versions before 2.12.7
- Remediation
- Update to 2.12.7 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Welcart e-Commerce on WPSec AttackSurface
- Fix released
- Published
Description
The Welcart e-Commerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'ResponseCd' (WelcartPay/e-SCOTT) and 'err_code' (ZEUS) parameters on the payment error page in all versions up to, and including, 2.12.6 due to insufficient output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Exploitation requires the corresponding payment module to be in use.
References
- https://wpsec.com/vuln/WPSEC-2026-2354/
- https://plugins.svn.wordpress.org/usc-e-shop/tags/2.12.7/
- https://wordpress.org/plugins/usc-e-shop/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS