Vulnerabilities / Welcart e-Commerce / WPSEC-2026-2355
Welcart e-Commerce <= 2.12.6 - Unauthenticated Arbitrary Shortcode Execution via Inquiry Form
High 7.3
CWE-94Fixed in 2.12.7
- ID
- WPSEC-2026-2355
- Plugin
- Welcart e-Commerce (usc-e-shop)
- Affected
- all versions before 2.12.7
- Remediation
- Update to 2.12.7 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weakness
- CWE-94
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Welcart e-Commerce on WPSec AttackSurface
- Fix released
- Published
Description
The Welcart e-Commerce plugin for WordPress is vulnerable to Arbitrary Shortcode Execution via the inquiry form in all versions up to, and including, 2.12.6 due to the sender-supplied inquiry content being passed through do_shortcode when building the customer and manager inquiry e-mails. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The sender's input was also inserted unescaped into HTML inquiry mails, allowing HTML injection.
References
- https://wpsec.com/vuln/WPSEC-2026-2355/
- https://plugins.svn.wordpress.org/usc-e-shop/tags/2.12.7/
- https://wordpress.org/plugins/usc-e-shop/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS