Vulnerabilities / WowStore / WPSEC-2026-2359
WowStore <= 4.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Product Block Attributes
Medium 6.4
CWE-79Fixed in 4.6.1
- ID
- WPSEC-2026-2359
- Plugin
- WowStore – Store Builder & Product Blocks for WooCommerce (product-blocks)
- Affected
- from 4.0.0 before 4.6.1
- Remediation
- Update to 4.6.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- WowStore on WPSec AttackSurface
- Fix released
- Published
Description
The Store Builder & Product Blocks for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'tooltipPosition' and 'className' attributes of its product grid and list blocks in versions 4.0.0 up to, and including, 4.6.0 due to insufficient output escaping. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2359/
- https://plugins.svn.wordpress.org/product-blocks/tags/4.6.1/
- https://wordpress.org/plugins/product-blocks/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS