Vulnerabilities / All In One Login / WPSEC-2026-2365

All In One Login <= 2.5.0 - Authenticated (Administrator+) Missing Authorization to Network Settings Disclosure

Low 2.7 CWE-285Fixed in 2.5.1
ID
WPSEC-2026-2365
Plugin
All In One Login (change-wp-admin-login)
Affected
from 2.5.0 before 2.5.1
Remediation
Update to 2.5.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-285
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
All In One Login on WPSec AttackSurface
Fix released
Published

Description

The All In One Login plugin for WordPress is vulnerable to unauthorized access of data due to an insufficient permission check on the network settings REST read endpoint in version 2.5.0. The endpoint allowed any user with the manage_options capability, not only network administrators, to read the network settings payload, which includes stored captcha secret keys and the list of sites on the network. This makes it possible for authenticated attackers with site-level Administrator access on a multisite network to read network-level settings that should be restricted to Super Admins.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0