Vulnerabilities / WCFM Marketplace / WPSEC-2026-2375
WCFM Marketplace <= 3.8.3 - Authenticated (Store Vendor+) Stored Cross-Site Scripting via Store Phone, Email, Support and Social Profile Fields
Medium 6.4
CWE-79Fixed in 3.8.4
- ID
- WPSEC-2026-2375
- Plugin
- WCFM Marketplace – Multivendor Marketplace for WooCommerce (wc-multivendor-marketplace)
- Affected
- all versions before 3.8.4
- Remediation
- Update to 3.8.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
- Attack surface
- WCFM Marketplace on WPSec AttackSurface
- Fix released
- Published
Description
The WCFM Marketplace plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the vendor store phone, email, customer support and social profile fields in all versions up to, and including, 3.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with vendor-level access to inject arbitrary web scripts that execute whenever a user, including an administrator, views the store page, the product page's store tab, the [wcfm_store_info] shortcode output or the admin vendor list.
References
- https://wpsec.com/vuln/WPSEC-2026-2375/
- https://plugins.svn.wordpress.org/wc-multivendor-marketplace/tags/3.8.4/
- https://wordpress.org/plugins/wc-multivendor-marketplace/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS