Vulnerabilities / WP User Merger / WPSEC-2026-2377

WP User Merger <= 1.6.5 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Display Name

Medium 5.4 CWE-79Fixed in 1.6.6
ID
WPSEC-2026-2377
Plugin
WP User Merger (wp-user-merger)
Affected
all versions before 1.6.6
Remediation
Update to 1.6.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
WP User Merger on WPSec AttackSurface
Fix released
Published

Description

The WP User Merger plugin for WordPress is vulnerable to Stored Cross-Site Scripting via a user's display name on the plugin's merge page in all versions up to, and including, 1.6.5 due to insufficient output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject web scripts into their profile that execute if an administrator selects that user for a merge and performs a further action on the page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0