Vulnerabilities / GeoDirectory / WPSEC-2026-2381

GeoDirectory <= 2.8.200 - Authenticated (Contributor+) Stored Cross-Site Scripting via gd_dynamic_content Shortcode

Medium 6.4 CWE-79Fixed in 2.8.201
ID
WPSEC-2026-2381
Plugin
GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (geodirectory)
Affected
all versions before 2.8.201
Remediation
Update to 2.8.201 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
GeoDirectory on WPSec AttackSurface
Fix released
Published

Description

The GeoDirectory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'html' attribute of the gd_dynamic_content shortcode in all versions up to, and including, 2.8.200. This is due to insufficient input sanitization and output escaping of the attribute and of the HTML built from %%variable%% replacement with listing field values. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0