Vulnerabilities / GeoDirectory / WPSEC-2026-2382

GeoDirectory <= 2.8.200 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Nested Shortcode Injection in Listing Content

Medium 6.4 CWE-79Fixed in 2.8.201
ID
WPSEC-2026-2382
Plugin
GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (geodirectory)
Affected
all versions before 2.8.201
Remediation
Update to 2.8.201 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
GeoDirectory on WPSec AttackSurface
Fix released
Published

Description

The GeoDirectory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via listing content in all versions up to, and including, 2.8.200. This is due to the content sanitizer stripping shortcodes in a single pass, so nested input such as a shortcode name split by an inner shortcode is reassembled into a working shortcode once the inner one is removed. This makes it possible for authenticated attackers, with subscriber-level access and above who can submit listings, to execute arbitrary shortcodes such as gd_dynamic_content with HTML and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0