Vulnerabilities / Fluent Support – Helpdesk & Customer Support Ticket System / WPSEC-2026-2392
Fluent Support – Helpdesk & Customer Support Ticket System <= 2.4.7 - Authenticated (Support Agent+) Missing Authorization to Ticket Agent Assignment via 'agent_id' Parameter
Low 2.7
CWE-862Fixed in 2.5.0
- ID
- WPSEC-2026-2392
- Plugin
- Fluent Support – Helpdesk & Customer Support Ticket System (fluent-support)
- Affected
- all versions before 2.5.0
- Remediation
- Update to 2.5.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
- Attack surface
- Fluent Support – Helpdesk & Customer Support Ticket System on WPSec AttackSurface
- Fix released
- Published
Description
The Fluent Support – Helpdesk & Customer Support Ticket System plugin for WordPress is vulnerable to Missing Authorization via the 'agent_id' parameter of the agent ticket creation REST endpoint in all versions up to, and including, 2.4.7, due to the endpoint not checking the 'Assign Agents' permission before storing a submitted agent_id on the new ticket. This makes it possible for authenticated support agents who may manage tickets but not assign agents to create tickets assigned to any agent.
References
- https://wpsec.com/vuln/WPSEC-2026-2392/
- https://plugins.svn.wordpress.org/fluent-support/tags/2.5.0/
- https://wordpress.org/plugins/fluent-support/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS