Vulnerabilities / Advanced Woo Search / WPSEC-2026-2409
Advanced Woo Search <= 3.73 - Unauthenticated Sensitive Information Exposure via Search Results Cache
Low 3.1
CWE-524Fixed in 3.74
- ID
- WPSEC-2026-2409
- Plugin
- Advanced Woo Search – Product Search for WooCommerce (advanced-woo-search)
- Affected
- all versions before 3.74
- Remediation
- Update to 3.74 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- Weakness
- CWE-524
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Advanced Woo Search on WPSec AttackSurface
- Fix released
- Published
Description
The Advanced Woo Search plugin for WordPress is vulnerable to Sensitive Information Exposure via the search results cache in all versions up to, and including, 3.73. Logged-in users with no role on the site shared one cache entry with logged-out visitors. This makes it possible for unauthenticated attackers to read search results cached for such a user, including products that another plugin hides from logged-out visitors, when search caching is on and such a user has searched the same term.
References
- https://wpsec.com/vuln/WPSEC-2026-2409/
- https://plugins.svn.wordpress.org/advanced-woo-search/tags/3.74/
- https://wordpress.org/plugins/advanced-woo-search/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS