Vulnerabilities / Elementor / WPSEC-2026-2415
Elementor <= 4.3.5 - Reflected Cross-Site Scripting via 'active-tab' and 'active-document' Parameters
Medium 6.1
CWE-79Fixed in 4.3.6
- ID
- WPSEC-2026-2415
- Plugin
- Elementor Website Builder – more than just a page builder (elementor)
- Affected
- from 3.21.0 before 4.3.6
- Remediation
- Update to 4.3.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
- Attack surface
- Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Elementor Website Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'active-tab' and 'active-document' parameters in versions 3.21.0 up to, and including, 4.3.5 due to insufficient input sanitization of these values when they are added to the Edit with Elementor link, and insufficient output escaping of that link. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user, such as an administrator, into performing an action like clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2415/
- https://plugins.svn.wordpress.org/elementor/tags/4.3.6/
- https://wordpress.org/plugins/elementor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS