Vulnerabilities / Elementor / WPSEC-2026-2416

Elementor <= 4.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Atomic Element ID

Medium 6.4 CWE-79Fixed in 4.3.6
ID
WPSEC-2026-2416
Plugin
Elementor Website Builder – more than just a page builder (elementor)
Affected
from 4.1.0 before 4.3.6
Remediation
Update to 4.3.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
Attack surface
Elementor on WPSec AttackSurface
Fix released
Published

Description

The Elementor Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Atomic element IDs in versions 4.1.0 up to, and including, 4.3.5 due to element IDs being concatenated into Alpine.js expressions in atomic widget templates without restricting them to safe identifier characters. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary JavaScript that will execute whenever a user accesses an affected page. Exploitation requires the Atomic Widgets feature to be active, which is the default on sites first installed at version 4.0.0 or later.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0