Vulnerabilities / Advanced Custom Fields (ACF®) / WPSEC-2026-2423
Advanced Custom Fields (ACF®) <= 6.8.10 - Unauthenticated Sensitive Information Exposure via Password-Protected Post Field Values
Medium 5.3
CWE-200Fixed in 6.8.11
- ID
- WPSEC-2026-2423
- Plugin
- Advanced Custom Fields (ACF®) (advanced-custom-fields)
- Affected
- all versions before 6.8.11
- Remediation
- Update to 6.8.11 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Advanced Custom Fields (ACF®) on WPSec AttackSurface
- Fix released
- Published
Description
The Advanced Custom Fields (ACF®) plugin for WordPress is vulnerable to Sensitive Information Exposure via the REST API, the [acf] shortcode, block bindings and JSON-LD output in all versions up to, and including, 6.8.10. This is due to field values being loaded and output without checking whether the post is password protected and its password has been entered. This makes it possible for unauthenticated attackers to read ACF field values of password-protected posts without knowing the password, for example through the REST API when the field group is shown in REST.
References
- https://wpsec.com/vuln/WPSEC-2026-2423/
- https://plugins.svn.wordpress.org/advanced-custom-fields/tags/6.8.11/
- https://wordpress.org/plugins/advanced-custom-fields/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS