Vulnerabilities / BuddyDrive / WPSEC-2026-2426

BuddyDrive <= 2.1.4 - Authenticated (Subscriber+) Sensitive Information Exposure via Group Lookup

Medium 4.3 CWE-200Fixed in 2.1.5
ID
WPSEC-2026-2426
Plugin
BuddyDrive (buddydrive)
Affected
all versions before 2.1.5
Remediation
Update to 2.1.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
BuddyDrive on WPSec AttackSurface
Fix released
Published

Description

The BuddyDrive plugin for WordPress is vulnerable to Sensitive Information Exposure via the buddydrive_get_bpobjects AJAX action in all versions up to, and including, 2.1.4, due to the user-supplied user_id parameter being used without an authorization check when groups are looked up. This makes it possible for authenticated attackers, with subscriber-level access and above, to list the BuddyDrive-enabled groups, including hidden groups, that any other user belongs to.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0