Vulnerabilities / WP Popular Posts / WPSEC-2026-2431

WP Popular Posts <= 7.4.3 - Unauthenticated Sensitive Information Exposure via 'post_type' Parameter of the Widget REST Endpoint

Medium 5.3 CWE-200Fixed in 7.4.4
ID
WPSEC-2026-2431
Plugin
WP Popular Posts (wordpress-popular-posts)
Affected
from 5.4.0 before 7.4.4
Remediation
Update to 7.4.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-04
Attack surface
WP Popular Posts on WPSec AttackSurface
Fix released
Published

Description

The WP Popular Posts plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'post_type' parameter of the /wordpress-popular-posts/v2/widget REST API endpoint in all versions up to, and including, 7.4.3. This is due to the endpoint passing request parameters to the popular posts query without checking them against the public post types. This makes it possible for unauthenticated attackers to list published entries of non-public post types that have views or comments, and to read their titles, links and, through the excerpt option, their content.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0