Vulnerabilities / WP Popular Posts / WPSEC-2026-2433

WP Popular Posts <= 7.4.3 - Unauthenticated Sensitive Information Exposure of Unpublished WPML Translations

Low 3.7 CWE-200Fixed in 7.4.4
ID
WPSEC-2026-2433
Plugin
WP Popular Posts (wordpress-popular-posts)
Affected
all versions before 7.4.4
Remediation
Update to 7.4.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-04
Attack surface
WP Popular Posts on WPSec AttackSurface
Fix released
Published

Description

The WP Popular Posts plugin for WordPress is vulnerable to Sensitive Information Exposure via the popular posts REST API endpoints and widgets in all versions up to, and including, 7.4.3. This is due to the Translate::get_object_id() function returning the translated post ID from the 'wpml_object_id' filter without checking whether that translation is published. This makes it possible for unauthenticated attackers to view the title, link and content of unpublished (draft, pending or private) translations of popular posts, for example by passing the 'lang' parameter to the /v1/popular-posts endpoint, on sites that use WPML or a compatible multilingual plugin.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0