Vulnerabilities / Optimole / WPSEC-2026-2435

Optimole <= 4.2.17 - Authenticated (Contributor+) Stored Cross-Site Scripting via JSON-Escaped Image URLs

Medium 6.4 CWE-79Fixed in 4.2.18
ID
WPSEC-2026-2435
Plugin
Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization (optimole-wp)
Affected
all versions before 4.2.18
Remediation
Update to 4.2.18 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
Attack surface
Optimole on WPSec AttackSurface
Fix released
Published

Description

The Optimole plugin for WordPress is vulnerable to Stored Cross-Site Scripting via JSON-escaped (slashed) image URLs in all versions up to, and including, 4.2.17, due to insufficient input sanitization and output escaping. When the plugin rewrites image tags, it decodes \uXXXX escapes and HTML entities in slashed image source URLs and writes parts of the decoded value back into the tag without escaping, including the filename segment of offloaded image URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0