Event Tickets and Registration <= 5.30.3 - Unauthenticated Sensitive Information Exposure via Attendee and Ticket Event Status Filter
- ID
- WPSEC-2026-2436
- Plugin
- Event Tickets and Registration (event-tickets)
- Affected
- from 4.8 before 5.30.3.1
- Remediation
- Update to 5.30.3.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-863
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
- Attack surface
- Event Tickets and Registration on WPSec AttackSurface
- Fix released
- Published
Description
The Event Tickets and Registration plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'post_status' parameter of the REST API attendee and ticket archive endpoints in all versions up to, and including, 5.30.3. This is due to an incorrect authorization check in the event status filter of the attendee and ticket repositories. For users without the read_private_posts capability, the filter built a publish-only list of statuses, but the query still used the unrestricted statuses the user supplied. This makes it possible for unauthenticated attackers to retrieve attendee and ticket data belonging to private or draft events.
References
- https://wpsec.com/vuln/WPSEC-2026-2436/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3.1/
- https://wordpress.org/plugins/event-tickets/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS