Vulnerabilities / Gallery : FooGallery / WPSEC-2026-2440
Gallery : FooGallery <= 3.3.17 - Authenticated (Contributor+) Sensitive Information Exposure via Gallery Shortcode and Block
Medium 4.3
CWE-200Fixed in 3.3.26
- ID
- WPSEC-2026-2440
- Plugin
- FooGallery Photo Gallery : Image, Video & Masonry Galleries (foogallery)
- Affected
- all versions before 3.3.26
- Remediation
- Update to 3.3.26 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
- Attack surface
- Gallery : FooGallery on WPSec AttackSurface
- Fix released
- Published
Description
The FooGallery Photo Gallery plugin for WordPress is vulnerable to Sensitive Information Exposure via the foogallery shortcode, the gallery block and the block-renderer REST route in all versions up to, and including, 3.3.17. This is due to the gallery renderer loading a gallery by its ID without checking the gallery's post status. This makes it possible for authenticated attackers, with Contributor-level access and above, to embed or preview private and draft galleries they are not permitted to read and view their images and captions.
References
- https://wpsec.com/vuln/WPSEC-2026-2440/
- https://plugins.svn.wordpress.org/foogallery/tags/3.3.26/
- https://wordpress.org/plugins/foogallery/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS